[nSign Desktop] Add Service Provider (CSMS) Troubleshooting Guide

[nSign Desktop] Add Service Provider (CSMS) Troubleshooting Guide

Problem: "Error adding service provider" or "Add service provider server failed"


The connection from the client to the server endpoint is blocked.

Troubleshooting steps

1. Check that the service provider is whitelist in your network. Review your network, policies, firewall and or proxies.
2. Conduct connectivity test to check that you are able to reach the server:
a. Using a browser, navigate to https://app1.sla.gov.sg/nSignDispatcher/clientapi/v3/auth, you should see the following page:



b. Using Command Prompt, CURL to curl --request POST "https://app1.sla.gov.sg/nSignDispatcher/clientapi/v3/auth", you should see the following error:



3. If the tests in 2a and 2b showed similar results, the client is able to establish connectivity to the server. Please proceed to Add Service Provider.